Examples

Contents

Examples#

This page contains a few examples of how you can use HyFI-ABSA package.

Installation#

You can install HyFI-ABSA using pip:

pip install hyfi-absa
Requirement already satisfied: hyfi-absa in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (0.5.1)
Requirement already satisfied: click<9.0.0,>=8.1.3 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi-absa) (8.1.7)
Requirement already satisfied: hyfi<2.0.0,>=1.36.3 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi-absa) (1.36.3)
Requirement already satisfied: openai<1.17.0,>=1.0.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi-absa) (1.16.2)
Requirement already satisfied: tenacity<9.0.0,>=8.2.3 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi-absa) (8.2.3)
Requirement already satisfied: chardet<=5.2.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (5.2.0)
Requirement already satisfied: colorama<0.5.0,>=0.4.3 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (0.4.6)
Requirement already satisfied: datasets<=2.18.0,>=2.0.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (2.18.0)
Requirement already satisfied: gdown<=5.1.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (5.1.0)
Requirement already satisfied: hydra-colorlog<2.0.0,>=1.2.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (1.2.0)
Requirement already satisfied: hydra-core<2.0.0,>=1.3.2 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (1.3.2)
Requirement already satisfied: joblib<=1.3.2,>=1.2.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (1.3.2)
Requirement already satisfied: matplotlib<=3.7.1 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (3.7.1)
Requirement already satisfied: numpy<=1.26.4,>=1.26.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (1.26.4)
Requirement already satisfied: pandas<=2.2.1,>=1.5.3 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (2.2.1)
Requirement already satisfied: pathspec>=0.9.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (0.12.1)
Requirement already satisfied: pyarrow<=15.0.2 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (15.0.2)
Requirement already satisfied: pydantic<3.0.0,>=2.3.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (2.6.4)
Requirement already satisfied: pydantic-settings<3.0.0,>=2.0.1 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (2.2.1)
Requirement already satisfied: python-dotenv<2.0.0,>=1.0.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (1.0.1)
Requirement already satisfied: scipy<=1.12.0,>1.10.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (1.12.0)
Requirement already satisfied: tqdm<5.0.0,>=4.64.1 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hyfi<2.0.0,>=1.36.3->hyfi-absa) (4.66.2)
Requirement already satisfied: anyio<5,>=3.5.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from openai<1.17.0,>=1.0.0->hyfi-absa) (4.3.0)
Requirement already satisfied: distro<2,>=1.7.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from openai<1.17.0,>=1.0.0->hyfi-absa) (1.9.0)
Requirement already satisfied: httpx<1,>=0.23.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from openai<1.17.0,>=1.0.0->hyfi-absa) (0.27.0)
Requirement already satisfied: sniffio in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from openai<1.17.0,>=1.0.0->hyfi-absa) (1.3.1)
Requirement already satisfied: typing-extensions<5,>=4.7 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from openai<1.17.0,>=1.0.0->hyfi-absa) (4.11.0)
Requirement already satisfied: idna>=2.8 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from anyio<5,>=3.5.0->openai<1.17.0,>=1.0.0->hyfi-absa) (3.6)
Requirement already satisfied: exceptiongroup>=1.0.2 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from anyio<5,>=3.5.0->openai<1.17.0,>=1.0.0->hyfi-absa) (1.2.0)
Requirement already satisfied: filelock in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (3.13.3)
Requirement already satisfied: pyarrow-hotfix in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (0.6)
Requirement already satisfied: dill<0.3.9,>=0.3.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (0.3.8)
Requirement already satisfied: requests>=2.19.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (2.31.0)
Requirement already satisfied: xxhash in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (3.4.1)
Requirement already satisfied: multiprocess in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (0.70.16)
Requirement already satisfied: fsspec<=2024.2.0,>=2023.1.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from fsspec[http]<=2024.2.0,>=2023.1.0->datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (2024.2.0)
Requirement already satisfied: aiohttp in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (3.9.3)
Requirement already satisfied: huggingface-hub>=0.19.4 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (0.22.2)
Requirement already satisfied: packaging in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (24.0)
Requirement already satisfied: pyyaml>=5.1 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (6.0.1)
Requirement already satisfied: beautifulsoup4 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from gdown<=5.1.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (4.12.3)
Requirement already satisfied: certifi in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from httpx<1,>=0.23.0->openai<1.17.0,>=1.0.0->hyfi-absa) (2024.2.2)
Requirement already satisfied: httpcore==1.* in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from httpx<1,>=0.23.0->openai<1.17.0,>=1.0.0->hyfi-absa) (1.0.5)
Requirement already satisfied: h11<0.15,>=0.13 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from httpcore==1.*->httpx<1,>=0.23.0->openai<1.17.0,>=1.0.0->hyfi-absa) (0.14.0)
Requirement already satisfied: colorlog in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hydra-colorlog<2.0.0,>=1.2.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (6.8.2)
Requirement already satisfied: omegaconf<2.4,>=2.2 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hydra-core<2.0.0,>=1.3.2->hyfi<2.0.0,>=1.36.3->hyfi-absa) (2.3.0)
Requirement already satisfied: antlr4-python3-runtime==4.9.* in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from hydra-core<2.0.0,>=1.3.2->hyfi<2.0.0,>=1.36.3->hyfi-absa) (4.9.3)
Requirement already satisfied: contourpy>=1.0.1 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from matplotlib<=3.7.1->hyfi<2.0.0,>=1.36.3->hyfi-absa) (1.2.1)
Requirement already satisfied: cycler>=0.10 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from matplotlib<=3.7.1->hyfi<2.0.0,>=1.36.3->hyfi-absa) (0.12.1)
Requirement already satisfied: fonttools>=4.22.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from matplotlib<=3.7.1->hyfi<2.0.0,>=1.36.3->hyfi-absa) (4.51.0)
Requirement already satisfied: kiwisolver>=1.0.1 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from matplotlib<=3.7.1->hyfi<2.0.0,>=1.36.3->hyfi-absa) (1.4.5)
Requirement already satisfied: pillow>=6.2.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from matplotlib<=3.7.1->hyfi<2.0.0,>=1.36.3->hyfi-absa) (10.3.0)
Requirement already satisfied: pyparsing>=2.3.1 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from matplotlib<=3.7.1->hyfi<2.0.0,>=1.36.3->hyfi-absa) (3.1.2)
Requirement already satisfied: python-dateutil>=2.7 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from matplotlib<=3.7.1->hyfi<2.0.0,>=1.36.3->hyfi-absa) (2.9.0.post0)
Requirement already satisfied: importlib-resources>=3.2.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from matplotlib<=3.7.1->hyfi<2.0.0,>=1.36.3->hyfi-absa) (6.4.0)
Requirement already satisfied: pytz>=2020.1 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from pandas<=2.2.1,>=1.5.3->hyfi<2.0.0,>=1.36.3->hyfi-absa) (2024.1)
Requirement already satisfied: tzdata>=2022.7 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from pandas<=2.2.1,>=1.5.3->hyfi<2.0.0,>=1.36.3->hyfi-absa) (2024.1)
Requirement already satisfied: annotated-types>=0.4.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from pydantic<3.0.0,>=2.3.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (0.6.0)
Requirement already satisfied: pydantic-core==2.16.3 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from pydantic<3.0.0,>=2.3.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (2.16.3)
Requirement already satisfied: aiosignal>=1.1.2 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from aiohttp->datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (1.3.1)
Requirement already satisfied: attrs>=17.3.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from aiohttp->datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (23.2.0)
Requirement already satisfied: frozenlist>=1.1.1 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from aiohttp->datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (1.4.1)
Requirement already satisfied: multidict<7.0,>=4.5 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from aiohttp->datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (6.0.5)
Requirement already satisfied: yarl<2.0,>=1.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from aiohttp->datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (1.9.4)
Requirement already satisfied: async-timeout<5.0,>=4.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from aiohttp->datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (4.0.3)
Requirement already satisfied: zipp>=3.1.0 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from importlib-resources>=3.2.0->matplotlib<=3.7.1->hyfi<2.0.0,>=1.36.3->hyfi-absa) (3.18.1)
Requirement already satisfied: six>=1.5 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from python-dateutil>=2.7->matplotlib<=3.7.1->hyfi<2.0.0,>=1.36.3->hyfi-absa) (1.16.0)
Requirement already satisfied: charset-normalizer<4,>=2 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from requests>=2.19.0->datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (3.3.2)
Requirement already satisfied: urllib3<3,>=1.21.1 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from requests>=2.19.0->datasets<=2.18.0,>=2.0.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (2.2.1)
Requirement already satisfied: soupsieve>1.2 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from beautifulsoup4->gdown<=5.1.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (2.5)
Requirement already satisfied: PySocks!=1.5.7,>=1.5.6 in /opt/hostedtoolcache/Python/3.9.19/x64/lib/python3.9/site-packages (from requests[socks]->gdown<=5.1.0->hyfi<2.0.0,>=1.36.3->hyfi-absa) (1.7.1)
[notice] A new release of pip is available: 23.0.1 -> 24.0
[notice] To update, run: pip install --upgrade pip
Note: you may need to restart the kernel to use updated packages.

Usage#

from hyabsa import get_version

print(get_version())